网站模板下载

system libzip must be upgraded to version >= 0.11

作者 libzip 2020-06-5 511

PHP当前最新版本是PHP7.3,今天在尝试安装的过程中报如下错误: system libzip must be upgraded to version >= 0.11, 根据提示我们可以清楚的知道是因为系统自带的libzip版本低了,这里我们需要安装最新的libzip-1.6.1,最新版本可以到libzip官网查看:https://libzip.org/

首先,卸载系统自带的libzip

1
yum  -y remove libzip-devel

然后从官网下载并编译安装

1
2
3
4
5
wget https://libzip.org/download/libzip-1.3.2.tar.gz
tar xvf libzip-1.3.2.tar.gz
cd libzip-1.3.2
./configure
make && make install

如果是下载1.5.*以上版本,则需要采用如下安装方式

1
2
3
4
5
6
7
8
yum -y install cmake
wget https://libzip.org/download/libzip-1.6.1.tar.gz
tar -zxvf libzip-1.6.1.tar.gz
cd libzip-1.6.1
mkdir build
cd build
cmake ..
make && make install
分享给朋友 system libzip must be upgraded to version >= 0.11-好哇网

点击【分享给朋友】生成专属代理二维码,享受推广消费现金奖励!

点击【分享给朋友】生成专属代理二维码,享受推广消费现金奖励!
好哇网 » system libzip must be upgraded to version >= 0.11

发表评论

好哇网,累计帮助1000+用户成功建站,为小微企业提供助力!

立刻开启你的建站之旅

留言咨询

现在加入好哇网,注册一个账号