好哇网

如何将 PHP 更新为 WordPress 建议的版本

作者 2021-07-15 471

使用过时版本的 WordPress 核心、插件或主题会使您的网站面临风险。PHP也不例外。

虽然 WordPress 在技术上可以与一些旧版本的 PHP 一起使用,但您正在牺牲性能和兼容性,同时使用这些会让自己面临安全漏洞。

为了安全和稳定性,始终致力于使用 WordPress 推荐的 PHP 版本。

在这篇文章中,我们将讨论如何检查您正在运行的 PHP 版本,并将您的 PHP 更新到推荐的 WordPress 版本。

如何将 PHP 更新为 WordPress 建议的版本-好哇网

重视 PHP

如果您查看 WordPress 站点文件夹,您会看到很多 PHP 文件。

由于 PHP 为大部分核心 WordPress 软件提供支持,因此它是 WordPress 社区非常重要的语言。

PHP 在各种平台上运行(Windows、Linux、Unix、Mac OS X 等),并且与当今使用的几乎所有服务器(Apache、IIS 等)兼容。

它不仅是 WordPress 的主要部分,还是整个网络的主要部分,为 70% 的网站提供支持。

WordPress 支持许多版本的 PHP,有些甚至已经过时,但作为一般规则,您应该只使用那些具有安全性或稳定支持的版本。

WordPress核心正式支持PHP 5.6.20 到 PHP 8.0,但是,并非所有主题或插件都受支持。

WordPress 目前最适合以下版本:

  • PHP 8.0
  • PHP 7.4
  • PHP 7.3

WordPress 建议的版本

PHP 必须定期更新,就像 WordPress 核心、主题和插件一样。

对于 PHP,每个版本在初始发布后获得两年的支持,然后有一年的时间仅根据需要发布关键安全更新。三年后,该版本的 PHP 不再受支持。

你可以访问WP官方查看建议的版本,截至 2021 年 7 月,目前 WordPress 推荐的 PHP 版本为7.4 或更高版本。

优质的托管服务提供商通常会要求您使用 WP 推荐的 PHP 版本才能使用他们的服务器,并且会帮助您修改您的站点以确保最新版本的 PHP 不会破坏它。

有时,某些第三方插件可能已过时并导致无法兼容最新版本的 PHP。

在这种情况下,您可以寻找更新、替代方案,或者在必要时将您的 PHP 版本降级到旧版本(只要安全补丁版本仍然积极支持它)。

0.7%的人使用PHP的最新版本8.0,而36.6%使用PHP的推荐版本7.4

信誉较差、价格低廉的主机不会主动鼓励您升级 PHP,因为需要额外的支持时间和资源来帮助您进行转换。

由于他们不想通过更新到推荐的 PHP 更新版本来破坏您的网站,因此他们通常会让您的网站使用过时的 PHP 版本,并希望它不被注意。

PHP 7.2 于 2017 年 11 月首次亮相。考虑到三年规则,我们知道它在 2020 年 11 月(以及之前更旧的 PHP 版本)达到了生命周期的结束。

这意味着超过三分之一 (37.2%) 的 WordPress 网站当前运行的 PHP 版本不再受到积极支持。

这还不是最糟糕的。从历史上看,这个数字在很长一段时间内一直徘徊在甚至超过三分之二(66%)!这是有问题的,原因有几个。

为什么要更新 PHP

速度

一方面,使用最新版本会带来巨大的性能优势。

根据Kinsta 进行的速度测试,跨 7 个 PHP 版本,请考虑以下统计数据:

如何将 PHP 更新为 WordPress 建议的版本-好哇网

PHP 版本显示出明显的速度差异

您可以从上表中看到,随着 PHP 的每个更新版本,每秒请求数逐渐增加。

由于使用推荐的 PHP 版本处理相同数量的请求所需的时间更少,因此您可以为访问者提供更好的用户体验。

Kinsta 还在 PHP 版本 8 上进行了测试,我确实想记下它的分数,因为速度的改进确实继续呈上升趋势。

凭借每秒 233.40 个请求的基准测试结果,PHP 8.0 比 PHP 7.4 有了巨大的飞跃,证明速度提高了 18.5%。

退后几个版本到 7.0,相比之下,它实际上每秒处理的请求多 50%。

我的图表中没有包含 PHP 8.0 版,因为它在一般 WordPress purlieu 中的支持很难评估。(WordPress 5.6 目前被认为与 PHP 8.0兼容。)

知道这一点,请谨慎行事并在将任何关键站点或客户端站点升级到 PHP 8.0 之前进行彻底的测试。

费用

维护代码需要付出努力,当您需要确保其他版本的向后兼容性时,这种努力就会成倍增加。

每当 WordPress 提高最低推荐的 PHP 版本时,过度工作的主题和插件开发人员都会松一口气,有效地将另一个过时的版本(及其所有相关的编码工作)排除在外。

与其花时间解析代码以确保对 PHP 的任何更改都不会影响它,开发人员可以花时间添加新功能或提高安全性。

漏洞

就像插件、主题和 WordPress 核心获得更新以修复安全漏洞一样,PHP 也是如此。

这也是为什么使用仍能获得更新的 PHP 版本如此重要的原因;它可以保护您免受 SQL 注入、XSS 和 DoS 攻击等漏洞的侵害。

根据安全漏洞数据源CVE 详细信息,2021 年初至今 PHP 中仅发现 2 个已知漏洞。

将此与 2020 年发现的 14 个漏洞、2018 年发现的 23 个漏洞和 2016 年发现的 105 个漏洞进行比较,您就会明白为什么更新可以帮助您抵御许多已知的安全漏洞。

事实上,一些黑客会通过查看您正在运行的 PHP 版本来确定哪种攻击有效。

对版本的厌恶?

兼容性的第一步是了解您的站点使用的 PHP 版本。

您可以直接在 WordPress 仪表板中轻松查看此信息。转至:工具>站点运行状况 > 状态。

如果您的站点应该使用较新版本的 PHP,它将显示在推荐的改进 下

否则,则打开已通过的测试部分进行验证。您会看到它说您的站点正在运行当前版本的 PHP,后面是括号中的版本号。

如何在 WordPress 中更新 PHP

一旦您检查了您的托管服务器正在运行的 PHP 版本,您就会知道是否需要升级到最新版本的 PHP。

如果这样做,则必须检查您的站点与新版本 PHP 的兼容性。您永远不想测试重大更改,例如在您的实时站点上更新您的 PHP,因为如果存在重大的不兼容性,您可能会严重阻碍或削弱您的站点。

因此,最好创建一个备用站点,您可以先在其中测试更改。

第 1 步:创建站点的副本

首先获取当前站点的副本。您将需要所有文件和数据库副本。

在某些情况下,如果您的备份同时包含文件和数据库,您或许可以使用上次备份。

您可以使用专门为此任务制作的插件来减轻负载。Duplicator是 WP.org 上提供的免费插件,获得了好评。

步骤 2:创建本地或临时站点

获得站点副本后,您需要设置测试环境。如果您的主机允许,您可以使用本地环境或设置临时环境*。

设置好测试环境后,您可以将上一步中的文件和数据库添加到测试环境中,这样您就拥有了实时站点的精确副本。

在测试环境中设置站点副本后,您就可以升级测试站点的 PHP 版本了。

检查 PHP 兼容性

现在是有趣的部分,我所说的有趣是指 QC 的乏味任务。

您需要通过您的测试站点以确保没有任何损坏。

仔细注意您网站的关键功能。查看流程、时事通讯注册、评论、Web 表单、导航以及有助于预期可用性和访问者参与度的所有其他元素。

您希望在任何问题有机会对您的实时网站造成严重破坏并为您的访问者或客户造成糟糕的用户体验之前发现它们。

方便的工具

有一些工具可以帮助开发人员和非开发人员进行 QC 过程。发现的任何超出您知识范围的问题都可以智能地转发给支持。

错误日志监视器– 此插件将在您的 WordPress 仪表板中显示 PHP 问题列表作为错误日志。

WP_DEBUG – 不是插件,而是 PHP 常量,这可用于触发整个 WordPress 的调试模式。

打开 WP_DEBUG 将允许您查看 PHP 故障类型,以便您可以在代码中修复它们。它还允许您查看在您的站点上运行的任何已弃用的功能(即那些存在于 WP 但不再是执行特定任务的标准方式)。

要打开调试,请前往您的 WordPress 安装文件,打开wp-config.php文件(位于根目录中),并在靠近底部的位置添加以下代码行:

<code class="  language-php" lang="php"><span class="token function">define</span><span class="token punctuation">(</span> <span class="token string single-quoted-string">'WP_DEBUG'</span><span class="token punctuation">,</span> <span class="token constant boolean">true</span> <span class="token punctuation">)</span><span class="token punctuation">;</span></code>

如果该行代码已存在但显示为false,请将其更改为true

解决问题

如果插件或主题导致问题,请先在您的测试站点上解决问题,然后找到与最新版本 PHP 兼容的合适替代方案。

找到解决方案后,请前往您的实时站点并在那里进行更改。

检测插件支持的PHP版本

当您在 WordPress 存储库中寻找合适的插件时,请记住检查支持的 PHP 版本。

一旦您解决了所有与兼容性有关的错误和问题,您就可以将临时网站推入实时状态,或对实时站点进行任何必要的更改,然后更改实时站点上的 PHP 版本。

此过程因主机而异,但很可能涉及更改主机 cPanel 中的设置。某些共享主机不允许您访问此设置,在这种情况下,您需要联系主机商寻求帮助。

总结

使用过时版本的 PHP 会使您的网站面临风险。虽然 WordPress 在技术上可以与一些旧版本的 PHP 一起使用,但您正在牺牲性能和兼容性,同时使用这些会让自己面临安全漏洞。

为了安全和稳定性,始终致力于使用 WordPress 推荐的 PHP 版本。始终建议搭建一个临时网站来测试并处理好兼容问题,然后才在正式网站上做更改。

发表评论

好哇网,每天提供1000+次下载,做你身边靠谱的下载站!

立刻探索下载

留言咨询